Setup requirementsΒΆ

A computer or device with the following is required:

  • 64-bit CPU
  • 64-bit operating system
  • 1GB RAM or better

The following are not requirements, but recommended:

  • Dual-core or better CPU

Note

PocketMine-MP is notoriously bad at multi-core usage. If purchasing a machine to run PocketMine-MP on, prefer higher CPU frequency instead of lots of cores.

We officially try to support Windows, Linux and MacOS platforms. However, in general any platform which will run 64-bit PHP with the required extensions will work.